Jak zmienić wartość parametru max_input_vars

Zdarza się, że nasza aplikacja wymaga większej wartości dla parametru max_input_vars. Pojawia się wówczas błąd, informacujący jaka wartość tego parametru będzie optymalna by aplikacja działała prawidłowo. Poniżej przedstawiona została instrukcja, jak dokonać zmiany tego parametru w poszczególnych Panelach Administracyjnych: cPanel i DirectAdmin.

cPanel

1) Na początek, należy zalogować się do cPanel pod adresem:

nazwa.kylos.pl/cpanel
domena.pl/cpanel

2) Następnie odnajdujemy sekcję: "Oprogramowanie", a w niej: "Wybór wersji PHP".


3) Klikamy: "Przejdź do ustawień PHP".


UWAGA:
Jeśli nasza bieżąca wersja PHP jest natywna np: native (5.6), to na początek należy zmienić wersje PHP na nienatywną. Jak dokonać zmiany wersji PHP, zostało opisane w artykule: https://panel.kylos.pl/knowledgebase/58/Jak-zmienic-wersje-PHP-na-swoim-koncie-przez-cPanel.html

4) W linii max_input_vars klikamy na wartość jaka jest przypisana do tego parametru. Pojawi sie rozwijane menu, z którego wybieramy nową wartość. Następnie klikamy na przycisk: "Zastosuj". Aby zmiany zostały wprowadzone, na koniec należy kliknąć: "Zapisz".



DirectAdmin

1) W pierwszej kolejności, należy zalogować się na na swoj serwer przez program np: Putty jako root. Pomocny w tym celu może być artykuł: https://panel.kylos.pl/knowledgebase/74/Jak-polaczyc-sie-z-serwerem-za-pomoca-SSH.html

2) W konsoli wydajemy polecenie:

vi /usr/local/php56/lib/php.ini


UWAGA
:
Polecenie to otwiera plik php.ini (i pozwala na jego edycję) dla wersji PHP 5.6 Jeśli chcesz zmienić wartość parametru max_input_vars dla innej wersji PHP, to wystarczy w miejscu: "php56" podać inne cyfry. Ważne jest by wersję PHP podać bez kropki.

3) Odnajdujemy wpis dotyczący parametru max_input_vars, zmieniamy jego wartość i zapisujemy zmiany.


4) Na koniec, należy wykonać dwa polecenia by wartość ta działała na serwerze dla wybranej wersji PHP.

service httpd restart

service php-fpm56 reload


UWAGA
:
Drugie polecenie jest dla wersji PHP 5.6 Jeśli edytowałeś wpis dla innej wersji PHP, to w miejscu: "php-fpm56", należy podać inne cyrfy. Ważne jest by wersję PHP podać bez kropki.

  • 1 Osoby uważają za pomocne
Czy ta odpowiedź była pomocna?

Podobne artykuły

Jak sprawdzić aktualnie włączone oraz wyłączone domyślnie moduły php

Twórcy aplikacji, w dokumentacji opisują jakie moduły, należy mieć włączone w konkretnej wersji...